Inbound Calls - Partial Disruption

Incident Report for Unzer

Resolved

The issue affecting our telephony hotline services has been resolved by our external partner. Inbound calls are now fully operational.
Posted Feb 19, 2026 - 12:34 CET

Update

We are continuing to work on a fix for this issue.
Posted Feb 19, 2026 - 10:17 CET

Identified

We are currently experiencing a service disruption affecting our telephony hotline services (Inbound Calls) due to an issue with our external provider.
Our teams are in close cooperation with the external provider and we are waiting their findings and resolution steps.
Posted Feb 19, 2026 - 10:17 CET
This incident affected: Support (Hotline).