PayPal - Service Disruption

Incident Report for Unzer

Resolved

This incident has been resolved.
Posted Jun 02, 2025 - 22:51 CEST

Monitoring

The impact has been mitigated, and since Monday, 2 June 2025 (CEST) 20:32, PayPal transactions are working as expected. We are awaiting final confirmation from PayPal's side.
Posted Jun 02, 2025 - 20:58 CEST

Identified

Please be informed that an external issue has been identified which is affecting PayPal payment method.
PayPal has acknowledged the issue and our teams are in close cooperation and we are waiting their findings and resolution steps.
Posted Jun 02, 2025 - 20:17 CEST
This incident affected: Unzer Processing (Alternative Payment Methods).