Degraded performance on Tillhub API

Incident Report for Unzer

Resolved

This incident has been resolved.
Posted Jan 23, 2026 - 15:17 CET

Monitoring

The incident affecting Tillhub performance has been resolved. The external upstream provider has restored the service and our metrics have returned to normal levels. We will continue to monitor.
If you still experience issues, please retry your request or contact our support team.
Posted Jan 23, 2026 - 11:00 CET

Investigating

We are investigating elevated latency and performance issues affecting Tillhub functionalities. Merchants may experience:

- Slow API responses
- Delays loading the dashboard/portal

Our engineering team is actively working to restore normal performance.
Posted Jan 23, 2026 - 09:39 CET
This incident affected: Tillhub Platform (API - Production, Dashboard Application - Production).