Missing BNPL transactions in Insights

Incident Report for Unzer

Resolved

This incident has been resolved.
Posted Jan 23, 2026 - 17:02 CET

Monitoring

We experienced a data import issue causing some Buy Now, Pay Later (BNPL) transactions not to appear in Merchant Portal Insights.
Issue has been identified and a fix has been deployed. New BNPL transactions are now importing as expected. We are monitoring the pipeline.
Posted Jan 23, 2026 - 11:42 CET
This incident affected: Online Portals (Unzer Insights - Production).