Incident - Mastercard Authentication Failures

Incident Report for Unzer

Resolved

This incident has been resolved.
Posted Jul 15, 2026 - 11:00 CEST

Identified

We are currently experiencing a service disruption affecting Mastercard authentications. At this time, all Mastercard authentication attempts are being rejected due to an issue on Mastercard side.

Our teams have been informed and are actively monitoring the situation with Mastercard.

We will share further updates as soon as more information becomes available.
Posted Jul 15, 2026 - 09:54 CEST
This incident affected: Unzer Processing (Credit Card).