eps - Service Disruption

Incident Report for Unzer

Resolved

This incident has been resolved.
Posted May 07, 2026 - 13:21 CEST

Monitoring

Please be informed that an external issue affected the EPS payment method between 07.05.2026 11:50 and 07.05.2026 12:22.
The issue has been resolved, and we are continuing to monitor the situation.
Posted May 07, 2026 - 12:57 CEST
This incident affected: Unzer Processing (Alternative Payment Methods) and Unzer Austria (mPAY24) (APM - EPS).