Service Disruption - POS Terminals (68xxxx)

Incident Report for Unzer

Resolved

This incident has been resolved.
Posted Apr 28, 2026 - 12:27 CEST

Identified

Please be informed of an incident involving an external provider that impacted all card types for terminal IDs beginning with 68xxxx. Our teams are in close communication with the provider and are currently awaiting their findings.
Posted Apr 28, 2026 - 10:32 CEST
This incident affected: Payment Terminal (TID 68xxx, 88xxx).