Service Disruption - POS Terminals for TID's 5xxx

Incident Report for Unzer

Resolved

This incident has been resolved.
Posted Oct 25, 2025 - 12:27 CEST

Identified

Dear customer,

An external issue has been identified affecting Credit Cards processing for card readers starting with terminal ID: 5xxx
Our teams are in close collaboration with the provider and an update will follow as soon as we have more information from the external provider.

Thank you for your patience and understanding.

With kind regards,

Your Unzer team
Posted Oct 25, 2025 - 11:14 CEST
This incident affected: Payment Terminal (TID 52xxx, TID 54xxx).