POS payout delay for 24/25.05.2025

Incident Report for Unzer

Resolved

This incident has been resolved.
Posted May 29, 2025 - 10:17 CEST

Identified

Please be informed that we are experiencing a merchant payouts delay affecting POS invoices, specifically for Saturday 24.05.2025 and Sunday 25.05.2025 transactions.
Our team has identified the root cause of the problem as external. Missing transactions and payouts will be considered on the next billing run.
Posted May 28, 2025 - 11:32 CEST
This incident affected: Billing (Settlement / Payout).