Email Delays Affecting BNPL

Incident Report for Unzer

Resolved

The issue affecting emails sent from our BNPL platform has been resolved. Our external email provider has confirmed that connectivity issues and sending delays have been fixed.

Email delivery should now be operating as expected.
Posted Jun 23, 2026 - 19:54 CEST

Identified

We are currently experiencing delays with emails sent from our BNPL platform due to an issue with an external email provider.
As a result, some emails may arrive later than expected, and in some cases customers may receive duplicate emails.

We are working to resolve the issue with our external provider and will provide updates as needed.
Posted Jun 23, 2026 - 15:12 CEST
This incident affected: Unzer Processing (Unzer PayLater).