Tillhub Dashboard – Product Import Issue (Excel/.xls)

Incident Report for Unzer

Resolved

This incident has been resolved.
Posted Sep 17, 2026 - 10:28 CEST

Identified

Merchants using the Tillhub Dashboard are currently unable to import products via Excel files (.xls format) due to a performance issue with the importer. Importing products via CSV format continues to work as expected.

Our team is in contact with the provider and we are waiting for their findings.
Posted Sep 16, 2026 - 20:07 CEST
This incident affected: Tillhub Platform (Dashboard Application - Production).