Unzer Insights - Transactions display delay

Incident Report for Unzer

Monitoring

We are seeing improvements from the external provider, and the Unzer Insights Portal is processing transactions again. We continue to monitor the situation closely and are awaiting final confirmation from the provider that the issue has been fully resolved.

Please note that this issue does not affect your shop’s transaction processing.
Posted May 14, 2026 - 11:02 CEST

Update

The issue is caused by an outage affecting an external partner. Our teams are actively monitoring the situation, and we are awaiting the provider’s findings and resolution.

Please note that this issue does not affect your shop’s transaction processing.
Posted May 14, 2026 - 09:50 CEST

Identified

Dear Unzer Insights user,

Please be informed that the Unzer Insights Portal is currently experiencing a disruption affecting delays in transaction display.

The issue has been identified, and our teams are working on it with high priority to restore normal service as soon as possible.

Please note that this issue does not affect your shop’s transaction processing.

We sincerely apologize for any inconvenience this may cause and thank you for your patience and understanding.
Posted May 14, 2026 - 09:07 CEST
This incident affects: Online Portals (Unzer Insights - Production, Unzer Insights - Sandbox).