Unzer PayLater Platform - Service Disruption
Incident Report for Unzer
Resolved
Dear customer,

We are pleased to inform you that the issue has been resolved. The affected service is functioning properly since 24.11.2023 16:02 (CET).

Quality and reliability are central aspects of our service delivery. If you require further information or support, please feel free to contact our Tech Experts Team (support@unzer.com) via email. Our team of specialists will contact you.

With kind regards,

Your Unzer team
Posted Nov 24, 2023 - 17:58 CET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 24, 2023 - 16:28 CET
Identified
Dear customer,

Our system is currently experiencing some disruption affecting PayLater processing platform. Our teams are working on this matter with high priority to restore the service to normal as soon as possible. We sincerely apologise for the inconvenience this caused you.

Thank you for your patience and understanding.

With kind regards,

Your Unzer team
Posted Nov 24, 2023 - 16:11 CET
This incident affected: Unzer Processing (Unzer PayLater).