Outbound and Inbound Calls - Partial Disruption

Incident Report for Unzer

Resolved

This incident has been resolved.
Posted Jun 29, 2026 - 18:15 CEST

Identified

We are currently experiencing a service disruption affecting our telephony hotline services due to an issue with our external provider.
Customers may be unable to reach our support teams via phone at this time. Our teams are in close cooperation with the external provider and we are waiting their findings and resolution steps.
Posted Jun 29, 2026 - 18:05 CEST
This incident affected: Support (Hotline).