Settlement / Payout delay
Incident Report for Unzer
Resolved
This incident has been resolved.
Posted Oct 27, 2023 - 17:13 CEST
Identified
Dear customer,

We regret to inform you that we are experiencing a Merchant Payouts delay. Our dedicated teams are actively working on resolving this matter with the highest priority to ensure a swift resolution.

Please note that this delay is impacting only a select group of merchants.

Thank you for your patience and understanding during this time.

With kind regards,

Your Unzer team
Posted Oct 25, 2023 - 14:53 CEST
This incident affected: Billing (Settlement / Payout).