PayLater Merchant Portal - Service Disruption

Incident Report for Unzer

Resolved

We are pleased to inform you that the issue has been resolved. PayLater Merchant Portal is now functioning properly again.

Quality and reliability are central aspects of our service delivery. If you require further information or support, please feel free to contact our Tech Experts Team (support@unzer.com) via email. Our team of specialist will contact you.
Posted Mar 24, 2025 - 12:00 CET

Investigating

Please be informed that the PayLater Merchant Portal is currently experiencing some disruption. Our teams are working on this matter with high priority to restore the service to normal operation as soon as possible. Please note that this will not affect your shop’s transaction processing.
Posted Mar 24, 2025 - 08:51 CET
This incident affected: Online Portals (PayLater Merchant Portal - Production).