Tillhub hotline service partial outage
Incident Report for Unzer
Resolved
Dear customer,

We are pleased to inform you that the issue has been resolved. The affected service is now functioning properly and the affected hotline is reachable as normal.

Quality and reliability are central aspects of our service delivery. If you require further information or support, please feel free to contact our Tech Experts Team (support@unzer.com) via email. Our team of specialist will contact you.

With kind regards,

Your Unzer team
Posted Jun 01, 2023 - 17:44 CEST
Identified
Dear customer,

Please be informed that the Tillhub hotline service is currently experiencing some disruption affecting Support hotlines. Our teams are working on this matter with high priority to restore the service to normal operation as soon as possible.

As a backup the following number can be called: +49 30 403668944

We sincerely apologise for the inconvenience this caused you.

Thank you for your patience and understanding.

With kind regards,

Your Tillhub team
Posted Jun 01, 2023 - 09:50 CEST
This incident affected: Support (Hotline).