Connection issue to Concardis (Nets) acquirer

Incident Report for Unzer

Resolved

This incident has been resolved.
Posted May 21, 2026 - 15:57 CEST

Monitoring

The external service disruption of Concardis (Nets) acquirer has been resolved and since 21.05.2026 14:43 the service is again operating under normal performance parameters. Monitoring is still ongoing.
Posted May 21, 2026 - 15:15 CEST

Identified

Payments with Concardis (Nets) acquirer are currently having problems due to connection issue on acquirer side.
We have reached out to the external provider and we are waiting for their findings and resoluiton.
Users may encounter difficulties when attempting to complete transactions using this specific acquirer.
Posted May 21, 2026 - 13:18 CEST
This incident affected: Unzer Processing (Credit Card), Acquirers, and Unzer Austria (mPAY24) (Credit Card Acquirer - Concardis / NETS).