TWINT - Service Degradation

Incident Report for Unzer

Resolved

This incident has been resolved.
Posted Jul 08, 2026 - 17:19 CEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 08, 2026 - 17:00 CEST

Update

A fix has been prepared and will be implemented in the next few minutes. We will continue to monitor the situation and share further updates as they become available.
Posted Jul 08, 2026 - 16:15 CEST

Identified

Please be informed that an external issue has been identified which is sporadically affecting the TWINT payment method. Our teams are working closely with the external provider, and we are currently awaiting their findings and resolution steps.
Posted Jul 08, 2026 - 14:46 CEST
This incident affected: Unzer Processing (Alternative Payment Methods).