Universum-Inkasso - Telephony hotline outage
Incident Report for Unzer
Resolved
This incident has been solved. Universum-Inkasso telephony hotline services are available again.
Posted Dec 05, 2024 - 14:09 CET
Identified
The issue has been identified and a fix is being implemented.
Posted Dec 05, 2024 - 13:16 CET
Investigating
We are currently experiencing an outage affecting our telephony hotline services for Universum-Inkasso. Customers may be unable to reach our support team via phone at this time. We are working to resolve the issue as quickly as possible and will provide updates as more information becomes available.
Posted Dec 05, 2024 - 11:05 CET
This incident affected: Support (Hotline).