Wero - Service Disruption

Incident Report for Unzer

Resolved

This incident has been resolved.
Posted Sep 07, 2026 - 21:03 CEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 07, 2026 - 20:35 CEST

Identified

We are currently experiencing issues affecting the Wero payment method. Our teams are aware of the situation and are in contact with the provider to investigate and resolve the issue as quickly as possible.

We will provide further updates as soon as more information becomes available.
Posted Sep 07, 2026 - 20:25 CEST
This incident affected: Unzer Processing (Alternative Payment Methods).