Payout delay for Secure Invoice
Incident Report for Unzer
Resolved
Dear customer,

We are pleased to inform you that the issue has been resolved. The affected service is now functioning properly again and the delayed Payouts are covered.

Quality and reliability are central aspects of our service delivery. If you require further information or support, please feel free to contact our Tech Experts Team (support@unzer.com) via email. Our team of specialists will contact you.

With kind regards,

Your Unzer team
Posted May 25, 2023 - 11:24 CEST
Identified
Dear customer,

Our system is currently experiencing some disruptions, resulting on payouts delay for Secure Invoice payment method.
Responsible teams are working on this matter with high priority to restore the service to normal as soon as possible. Please note that this will not affect your shop’s transaction processing.

We sincerely apologise for the inconvenience this caused you.

Thank you for your patience and understanding.

With kind regards,

Your Unzer team
Posted May 24, 2023 - 18:26 CEST
This incident affected: Unzer Processing (Alternative Payment Methods).