BNPL - Slower Transaction Processing Times

Incident Report for Unzer

Resolved

This incident has been resolved. Transactions processing times are back to normal values.
Posted Mar 25, 2026 - 14:53 CET

Monitoring

We are currently observing occasional slower transaction processing times for our Buy Now, Pay Later (BNPL) product.

The delays are caused by slower response times from external credit score services. As a result, some transactions may take longer than usual to complete.

Our teams are actively monitoring the situation and are in contact with the relevant external credit agencies to resolve the issue as quickly as possible.
Posted Mar 25, 2026 - 13:21 CET
This incident affected: Unzer Processing (Unzer PayLater).