Unzer Austria (mPAY24) - Paysafe outage
Incident Report for Unzer
Resolved
This incident has been resolved.
Posted Dec 06, 2023 - 19:30 CET
Investigating
Dear customer,

We would like to inform you about a disruption in the processing ofpayments via Paysafe.
The problem has already been identified, Paysafe is working on a solution.

Start Time: 2023-12-06 17:53
End Time: 2023-12-06 19:33

If you require further information or support, please feel free to contact our Tech Experts Team (support@unzer.com) via email.
Our team of specialists will contact you.

With kind regards,
Your Unzer team
Posted Dec 06, 2023 - 17:45 CET
This incident affected: Unzer Austria (mPAY24) (APM - Paysafecard).