BNPL - Slower Transaction Processing Times

Incident Report for Unzer

Resolved

This incident has been resolved.
Posted Jun 10, 2026 - 17:16 CEST

Monitoring

During the period from 10.06.2026 15:00 to 10.06.2026 16:15, we observed occasional slower transaction processing times for our Buy Now, Pay Later (BNPL) product.
The delays were caused by increased response times from external credit scoring services. As a result, some transactions may have taken longer than usual to complete.
Our teams are actively monitoring the situation and are in contact with the relevant external credit agencies.
Posted Jun 10, 2026 - 16:26 CEST
This incident affected: Unzer Processing (Unzer PayLater).