Unzer Insights - BNPL transactions display delay

Incident Report for Unzer

Resolved

The delay in displaying BNPL transactions in the Unzer Insights Portal has been resolved. All transactions are now visible as expected. Transaction processing was not impacted.
Posted Mar 02, 2026 - 21:05 CET

Identified

An issue has been identified affecting the Unzer Insights Portal. Specifically, delays in displaying BNPL transactions have been observed.

Our teams have identified the issue and are working with high priority to restore normal service as quickly as possible.

Please note that this does not affect your shop’s transaction processing.

The next update will be provided once transactions are displayed normally again.
Posted Mar 02, 2026 - 17:33 CET
This incident affected: Online Portals (Unzer Insights - Production).