BNPL payout delays (EUR, CHF)

Incident Report for Unzer

Resolved

Please be informed that the issue causing delays in BNPL merchant payouts in EUR and CHF has been resolved. Our banking partner has successfully addressed the software update that led to this problem. The issue has been resolved, and all EUR and CHF payments with the status “pending” have been successfully executed with today's exchange rate. We appreciate your patience and understanding during this time. If you have any questions, please feel free to reach out to our support team.
Posted Dec 12, 2025 - 18:03 CET

Identified

We are currently experiencing delays in BNPL merchant payouts in EUR and CHF due to an unexpected software update at our external banking partner. Our teams are working closely with the partner to restore normal payouts as a top priority. At this time, the impact is limited to a subset of merchants. Funds are secure and will be disbursed once the payout service resumes.

No action is required from your side. We will provide updates on this page as soon as new information is available.
Posted Dec 12, 2025 - 10:45 CET
This incident affected: Billing (Settlement / Payout).