Degraded performance on Tillhub API

Incident Report for Unzer

Resolved

This incident has been resolved.
Posted Jan 30, 2026 - 09:25 CET

Monitoring

We investigated elevated latency and performance issues affecting Tillhub functionalities between 30.01.2026 08:30 - 30.01.2026 08:42. During this time merchants may have experienced:

- Slow API responses
- Delays loading the dashboard/portal

Issue has been recovered from our our engineering team and we are actively monitoring the performance.
Posted Jan 30, 2026 - 08:51 CET
This incident affected: Tillhub Platform (API - Production, Dashboard Application - Production).